On this page:

13 Lazy Require

NOTE: This library is deprecated; use racket/lazy-require, instead. The contents of this module, with the exception below, have been merged with racket/lazy-require.

 (require unstable/lazy-require) package: unstable-lib


(begin-on-demand #:export (fun-id ...)
   body ...+)
Defines each fun-id as a function that, when called, dynamically loads and executes the body forms. The body forms must contain definitions for each fun-id, and the value of each fun-id must be a function.

A body form may be any module-level form except provide. In particular, require forms are allowed.

The body forms are placed within a submodule that extends the scope of the enclosing module (ie, module* with #f in the language position). Consequently, any references to sibling submodules must include a with ".." module path element.